In this article
The macOS Roaming Client may appear offline or not activate after installation, which means DNS traffic isn't filtering through DNSFilter.
This article outlines the symptoms, possible causes, and recommended resolutions to restore functionality and ensure uninterrupted DNS filtering.
Symptoms
These indicators suggest the macOS agent is offline:
- The Roaming Client icon in the menu bar displays an "x"
- The status in the menu bar shows "Offline"
- Roaming Client logs include errors related to binding issues with port 53
Possible Causes
A Roaming Client not coming online after installation is typically blocked by another security application interfering with the agent (including built-in Apple security settings):
- Antivirus programs can quarantine the Roaming Client
- A firewall might block UDP egress traffic on port 53
- Another application or service could be listening on port 53
Resolution Steps
To resolve this issue, perform these system checks and updates. As a general rule, always make sure all software is updated to the latest version to prevent compatibility issues.
Disable Internet Sharing |
Internet Sharing is an Apple setting that allows internet connection sharing to other devices on a local network. This setting can interfere with the Roaming Client, and disabling it can resolve the connection issue.
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Adjust firewall settings | Firewalls need to allow outbound traffic on port 53 (UDP) for the agent to function. |
Disable Docker auto-start | Depending on how the network's environment is configured, Docker could block the agent from coming online when the device powers on because it will bind to port 53 before the Roaming Client binds. Disable auto-start by adding a command to the specific container. |
Identify and disable Vnet drivers |
Confirm that no virtual network (Vnet) drivers are active on the device. These can cause mDNSResponder to proxy DNS and interfere with port 53 binding.
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If these steps do not resolve the issue, use this command to determine what application is listening on port 53 and send a screenshot of the results and Roaming Client diagnostic logs to our Support team: sudo lsof -i -P | grep LISTEN | grep :53
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